Error 28173 Installing VMware vSphere
in ,

Error 28173 Installing VMware vSphere Client 6

Let’s see how to fix error 28173 by installing VMWare vSphere Client 6.0. When installing VMware vSphere Client 6.0 (VMware-viclient-all-6.0.0-5112508) on a Windows Server 2012, server you might get this Error 28173, setup failed to enable Microsoft .NET Framework 3.5. This guide will provide you information on these issues where VMware Client 6.0 fails to install on Windows Server 2012 with the error 28173.

Error 28173 setup failed to enable

The Error 28173, Setup failed has to enable Microsoft .NET Framework 3.5 quote to Microsoft KB article 2734782 and 3002547 which may help you to resolve the issue .NET framework failure. You will need to enable this Windows feature in Server Manager before installing the vSphere Client.

This is caused because one of the VMware clients installs requirements .Net Framework 3.5 is missing.
To resolve this issue, open Server Manager and click Add roles and features.

Server Manager Dashboard

Add roles and features, select next.

Add role and feature wizard

Choose Role-based or feature-based option and then click Next.

Select installation type add role

Select the radio button “a server from the server pool” and then click Next.

Select server selections

Server Roles, click next.

Select server roles

Select.NET Framework 3.5 features and click next.

Select features .net framework 3.5

Click the install button.

Confirm installation selections

Server feature installation failed.

Features installation failed

If you get the above error then Follow this link to Enable .Net Framework features.

For more details please visit VMware

Written by Jamil Parvez

Jamil Pervez works as a Network Administrator, based in Kuwait with a Primary focus on Microsoft technologies. Microsoft Certified MCSE, MCTP, MCITP, CCNP, CCIP, CCVP with 18 years experience in administering Windows Servers, Exchange, VMWare, Veeam B&R, Veritas BackupExec.

Leave a Reply

.Net Framework 3.5 Installation Fails

.NET Framework 3.5 Feature Installation Fails Fixed

Install Deepin Desktop Community

How to Install Deepin Desktop Community